The E-Stop does not disengage

Hi Farm-NG team! We just transported our Amiga Robot for a 31-mile trip to a new location. Upon turning on, all the motors are in “red” and there is an indicator that the motors are “estopped”. We disengaged the e-stop switch and the motor status is still the same. I am sure the motors and controllers are ok since we just used the robot to move it to the transporting trailer. We suspect there is a problem with the e-stop system but we want to hear your diagnostics and solution to this problem. Thank you.

Hello @vanzky102, thank you for reaching out!

In order to better assist you I’d like to have a little more context. First, can you share your Amiga’s name? Additionally, can you please share pics of your dashboard on the e-stop screen and on the motors can screen? Here are the screens I’m referring to:

I was not able to get a screenshot but I can describe the status display. Based on the second image, we encounter this after boot-up. It says “No healthy motors…Check pressed E-stop”. We disengage e-stop, then click “CLEAR E-STOP” and then it goes similar to the second image but:

  1. all the motors (A, B, C and D) are red
  2. only the ESTOPPED is highlighted green above the motor status
  3. only the ACTIVE is highlighted green on the right

Thank you for the info!

So, it looks like you got your e-stop circuit open somewhere. A way to find the problem is to follow the M8 connectors and cables along the robot, starting by the ones connected to the physical E-Stop button. Here’s what they look like:

If the error won’t clear, try to remove the side pannels and check the M8 connectors as well:

If it is still not working, let us know!

Once again, thank you for reaching out!

Thank you for the suggestion. We will definitely try it. Quick question: on the first image, there is a connector on the side of the e-stop switch with a cut cable…is this is necessary? Ours did not have a connector connected. I am wondering if it is needed for termination.

That is correct. That is needed to close the loop and is most likely the cause of the error. Maybe it fell during the transport?

I believe it got loose and fell during transport. I reviewed images of the robot before and I can confirm that there was a connector attached. Where can we get that connector (that is terminated)? Is there a work around? Please advise, thanks.

So, the connector actually requires a couple of terminations to close the loop on the E-stop bus, so I believe it is better for us to get you a link to order a new one.

As we are in process of changing our online store, I do not have the link handy, but I will ask them to prioritize this and get you a link asap.

I hope I can get a link for a new connector since we need to move the robot again to another location again on Monday next week. Thanks!

I’ll be following up through messages to arrange shipment.

I’m sorry you have this inconvenience. Ping us if you have any other question and have a great week.

Thank you for the support. We truly appreciate it.

1 Like

Hi guys! It took us time to work on the robot but we managed it yesterday. The connector you sent actually solved the problem. It’s working perfectly now. Thank you very much guys for the support.

That’s great news! Thank you for posting here and looking forward to see how Amiga is helping you guys!