Amiga Unable to Detect Pendant

  • What package and version are you using ?

This was noticed when turning on the Amiga and attempting to disable the E-stop. Not directly related to configuring, more with the functionality of the machine itself.

  • Please, describe the issues you are seeing ?

Amiga unable to connect to pendant, resulting in inability to clear the internal e-Stop in order to control via to the virtual or physical joystick.

** Any possible information will make the live of the community members easy to reply and provide a solution.

Attached is a picture of the error screen:

Thanks in advance!


Sorry you’re having this issue. That error code means the pendant is completely undetected by the dashboard. Can you confirm the pendant is correctly connected into the back of the dashboard? And is there any illumination on the pendant keypad? When you do disconnect and re connect the pendant, it’s recommended you disconnect the power before you unplug / plug in components (I.e, avoid hot swapping).

Also, there is a version to the dashboard firmware that can be found on the Settings tab > ID page. It’s unrelated to the error you’re experiencing, but could be useful in the future if you experience any other issues with the dashboard.

— Kyle

As @kylecoble suggested it would be good to confirm some information and observations.

  • Was the pendant unplugged/plugged in before it stopped communication? Meaning was “sudden” or was it after being manipulated. If the pendant was being removed/reconnected it might not be fully seated, or something could have happened during reconnection.
  • Are the LEDs illuminating, which shows if power is being delivered, or if there is any internal regulator issues (shorts or damage)
  • Did it work recently? Did it stop working during use, or when powering up? Any more clarity of what happened, how it happened, and the order makes debugging much easier.

Until then we will assume that we might need to send a replacement and prepare a new devices. @Jerrycowell96 can you help make sure Berenice and I have their shipping and contact information.

Confirming the situation:

  • The pendant stopped functioning properly after being manipulated. We have terminated power and reseated the pendant multiple times with no change in detection.
  • The LEDs are not illuminating. There are no apparent internal regular issues.
  • When we first received the Amiga, the system functioned properly. We were able to control the motion of the robot. When we unplugged the system to examine the connections, it did not function after being reseated.

Quick update: We tried to attach a new E-stop M8-4 pin to the device. Now it won’t turn on at all. Any assistance?

Thanks for the added information on the pendant. I will check with @Jerrycowell96 and our production about a replacement.

Regarding the e-stop, I need more context.

  • Why did you change it? It is hard for some of the engineers to track all clients so helping make sure we understand the situation when you ask a question. This could arguably deserve another ticket/thread depending on the situation.
  • What is not turning on? The Amiga, pendant, dash, all of it?
  • Can you show images of the install? it requires termination and we need to double check that.

Please be as specific as possible so we avoid back and forth questions.

Hi Travis,
I’m also on the team with Carl. We didn’t replace the estop but noticed that there were 2 m8 4pins and wanted to use that estop to also be the estop for our linear actuator (which can supply 400lbs of force) since we are required to incorporate an estop.
We cannot tell if the Amiga is not turning on since both displays on our amiga, the brain and the nvidia, are no longer turning on. The estop is also not providing the red light that it usually uses. The one item that demonstrates that it is receiving power is on the box that the cameras plug into on the right side of the chassis in-between the wheels is displaying the green light that shows it is receiving power. Beyond that we are still not gaining any signal on the pendant which has not changed even with several reseatings into its m12 5pin connector slot.
I am not in the lab currently so I cannot show any images but the idea for the estop was to have one m8 4pin go to the amiga and control the estop of the motors and such like it currently does and utilize the second m8 4pin to provide power to our linear actuator since no other element requires us to utilize an estop.

My first suggestion is to revert back to the last wiring setup that worked because it sounds like you introduced an issues that could be faulting the system and potentially causing the batteries to fault and turn off.

It is still unclear how you are trying to utilize the e-stop for your actuator and you also mention powering your actuator. Without knowledge of how you are wiring or using it it is hard to debug from my side. In the e-stop circuit there is 48v and hooking that up wrong could cause damage or at least cause the batteries to turn of for safety, possibly blowing a fuse.

We would need more information on your wiring and how you expect to use it. I do think this is a separate issue than the pendant and it might be good to start a separate topic and tag me.