Dead Batteries (or faulty charger)

Hi farm-ng team!

After using the platform for several field operations, we encountered a sudden shutdown of the system. We thought it was the fuse but the fuse was ok. Upon checking the voltage output of the battery to the motor, the voltage is below 1 V. We find it strange since the dashboard did not prompt any low voltage warnings. So, we remove the batteries and plug ti to the charger. However, we noticed that the charger shows red and green LED status which means the battery is fully charged but we just plugged the battery. We suspect a faulty battery charger but also a faulty battery since it was fully discharged. Please let us know your opinion on this problem. We need to get the robot moving so that we can transport it to another location. Your prompt response is very much appreciated. Thank you.

Solved it. Nathan suggested to check the fuse on the battery and it was busted for both batteries. We replaced it with a 30A ordinary fuse and the battery worked. Checking online, we got this fuse which has the same part number of the busted fuses. Please confirm if this is the correct fuse so that we can purchase it. Thanks guys for the assistance.

Hello @vanzky102,

Glad to hear that worked!

Those fuses will work for you, and another option is:

YOLISTIC (Pack of 10) 30 Amp Slow-Blow Time Delay Fuse Ceramic 6x30mm

Please keep us posted if the behavior occurs regularly or any related observations come up.

– Kyle