Blown Fuse Problem

We experienced the Amiga not turning on when we turn the battery key on. Upon checking, it was the fuse on the output of the DC-DC converter. We replaced it and it works fine then it happened again. We replaced the fuse again and after a couple of minutes of operation, the dashboard and pendant would not turn on. Replacing the fuse might solve this problem temporarily but we need a more permanent solution. If you guys have a similar problem, please let us know on how did you resolve it. I hope the technical team from Farm_NG could also shed a light on this problem. Thank you.

Hello @vanzky102 ,

Sorry to hear about the issues you are experiencing with the DC-DC converter fuse. Can you please clarify which DC-DC converter on the amiga this is? Additionally, can you confirm the replacement fuses you tried were rated the same as the original fuse?

In order to better understand this issue, can you please share some more information about your system and the usage leading up.

  • Do you have a brain / intelligence kit?
  • Do you have any added on farm-ng implements (three point lift, compost spreader, etc.)?
  • Do you have any non farm-ng implements added onto your amiga?
  • Did you experience any intermittent errors on the dashboard leading up to this failure?
  • Can you please qualify how you typically use your amiga and how it was used leading up to this error? Was it sitting idle a long time? Is it used daily? Is it used for hauling heavy loads?

And please share any additional information you think may be relevant.

Thank you,
– Kyle

I was told to expect a Discourse message about a fuse issue. It was also mentioned that it is possible it is linked to the e-stop switch when pressed.

There are two main ways to isolate the issue. One might takes fuses, and one will use a multi-meter to probe resistance.

The crude way is to disconnect suspect devices, replace the fuse and the reconnect them and confirm the fuse blows. You can also disconnect everything and start from nothing. Just try to be methodical on tracking what could be causing it.

Another way to isolate this is with the fused removed use a multi-meter and probe resistance to ground from where the fuse is installed. Then try to recreate the situation that might blow the fuse. Resistance levels below ~1K ohms would l point to the component or device that is failing.

It sounded like the e-stop button was suspected to be the failure point, so it makes sense to start there. 24v from the DC/DC does go through that button to light the LED and is a possible locations for a short to happen.

I would also review Kyles questions, because often issues are introduced and understanding changes to the original Amiga might point to the cause, where the fuse blowing is only the symptom.

That is hopefully enough, if not Kyle and I can provide more details.

Hi Kyle!

  • We do not have an intelligence kit installed.
  • No added farm-ng implements installed.
  • We have a load added to the Amiga platform but it is self-powered, not drawing power from Amiga.
  • No intermittent errors on the dashboard.
  • It happened when we are loading the Amiga with the load to a trailer. The load we can say is within the capacity of the platform. It is not used daily for a long period (just short hops within the lab). After we solved the “Motor 12” problem, we moved the Amiga within the lab, so it was not idle for a long time.


Hi Travis!

After I made the troubleshooting based on the suggestion of the team, we found out that:

  • There was no ground short on the 24V output of the DC-DC converter.
  • We checked the wiring and we cannot find any shorts.

But on “Motor B” where the DC-DC converter was located, we noticed that the e-stop connector from the motor controller to the T-connector was frayed. The neck of the connector showed some damage. So we fixed it by using an electrical tape and re-organized the wiring to lessen the stress on that connector. We replaced the fuse and it worked. We loaded the Amiga with the load on the trailer. When we tried to turn on the Amiga for unloading, it happened again (the fuse is blown). So we removed the cover and let cable loose since the cover kind of pushed the cable in when installed. We replaced the fuse and the Amiga turned on and the fault never happened again even we load the Amiga back to the trailer.

So my theory is that somehow that frayed cable on the connector caused some shorting when it was under stress, thus generating the current spike. I will post a photo later of that connector. We will continue to observe if this problem will happen again. If you can give us a link where to purchase the connector for the e-stop, we will try to replace it.

Thanks again guys for your assistance. It really helped especially that we under tight schedule or we will miss the harvesting period. We successfully undertaken the experiment without that issue. The only minor problem we noticed that the motors gotten hot after a period of operating the Amiga. We just let it sit for while to cool down and we were back to business.


I am glad this seems resolved. I would be nice to see images of the issue. I can feed this back to deal with potential quality issues, as well as possibly provide new components to avoid future issues.

Can you also help us understand how it is being used that is causing the motors to get hot, is it just one or all of them?