Unable to view cameras or canbus info in Brain apps

  • What package and version are you using ?
    Copper Grapefruit

  • Please, describe the issues you are seeing ?
    I am unable to view OAK cameras or communicate with the Amiga over Canbus from the Brain when using default camera and virtual joystick apps. These previously worked, but now will not connect in the apps (nothing has changed since they previously worked). The camera screens are black and the Amiga state is not available.

The devices are being recognised in the settings menu (see screenshot).

Troubleshooting I have tried:

  • Power cycling the full system
  • Redoing all connections
  • Restarting devices in the settings menu

Thanks in advance!

Hi @Wes,

We’ve seen this grpc connection issue once in the past, where the connection does not occur between the device services and the apps using them when you are connected to a wifi network that does not have internet connectivity. We have not yet sat down to diagnose the root cause, but you could confirm whether this is the case by changing the wifi network the brain is connected to or connecting to a phone hotspot.

Please let me know how that goes.

– Kyle

1 Like

That fixed it, thanks Kyle!

OK great! We’ll still keep solving the root cause of this issue in our queue, but glad to know you won’t be blocked by this.

– Kyle